Wolf Creek Public Schools - Powerschool unavailable - Tue May 12, 2026 @ 3:45pm – Incident details
Get updates
Email
Slack
Microsoft Teams
Google Chat
Webhook
RSS
Atom
API
Get updates
Dark mode
All systems operational
Powerschool unavailable - Tue May 12, 2026 @ 3:45pm
Resolved
Major outage
Started 1 day ago
Lasted 23 minutes
Affected
PowerSchool
Major outage from 9:54 PM to 10:17 PM
Updates
Resolved
May 12, 2026 at 10:17 PM
Resolved
May 12, 2026 at 10:17 PM
This incident has been resolved.
Investigating
May 12, 2026 at 9:54 PM
Investigating
May 12, 2026 at 9:54 PM
We are currently investigating this incident.